Back to overview
Degraded
[Investigating] Laundry Access Issues
Apr 19, 2026 at 8:33am UTC
Affected services
Building System
Updated
Apr 19, 2026 at 8:55am UTC
A potential root cause has been identified and the team is working to verify a permanent solution. Scope indication is single digit users affected.
Expected resolution time: EOD 20/4. An interim mitigation is in place to ensure affected users still have access to booked slots.
Affected services
Created
Apr 19, 2026 at 8:33am UTC
User reports indicate an issue with access to laundry room during active bookings. The team is investigating and have taken steps to mitigate the issue temporarily.
Affected services